ipmitool.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404
  1. Name: ipmitool
  2. Summary: ipmitool - Utility for IPMI control
  3. Version: 1.8.18
  4. Release: 1%{?_distro:.%{_distro}}
  5. License: BSD
  6. Group: Utilities
  7. Packager: Jim Mankovich <jmank@hp.com>
  8. Source: %{name}-%{version}.tar.gz
  9. Buildroot: /var/tmp/ipmitool-root
  10. %description
  11. This package contains a utility for interfacing with devices that support
  12. the Intelligent Platform Management Interface specification. IPMI is
  13. an open standard for machine health, inventory, and remote power control.
  14. This utility can communicate with IPMI-enabled devices through either a
  15. kernel driver such as OpenIPMI or over the RMCP LAN protocol defined in
  16. the IPMI specification. IPMIv2 adds support for encrypted LAN
  17. communications and remote Serial-over-LAN functionality.
  18. It provides commands for reading the Sensor Data Repository (SDR) and
  19. displaying sensor values, displaying the contents of the System Event
  20. Log (SEL), printing Field Replaceable Unit (FRU) information, reading and
  21. setting LAN configuration, and chassis power control.
  22. %prep
  23. if [ "$RPM_BUILD_ROOT" ] && [ "$RPM_BUILD_ROOT" != "/" ]; then
  24. rm -rf $RPM_BUILD_ROOT
  25. fi
  26. %setup
  27. %build
  28. ./configure --with-kerneldir \
  29. --with-rpm-distro= \
  30. --prefix=%{_prefix} \
  31. --bindir=%{_bindir} \
  32. --sbindir=%{_sbindir} \
  33. --datadir=%{_datadir} \
  34. --includedir=%{_includedir} \
  35. --libdir=%{_libdir} \
  36. --mandir=%{_mandir} \
  37. --sysconfdir=%{_sysconfdir}
  38. make
  39. %install
  40. make DESTDIR=$RPM_BUILD_ROOT install-strip
  41. %clean
  42. if [ "$RPM_BUILD_ROOT" ] && [ "$RPM_BUILD_ROOT" != "/" ]; then
  43. rm -rf $RPM_BUILD_ROOT
  44. fi
  45. %files
  46. %defattr(755,root,root)
  47. %attr(755,root,root) %{_bindir}/*
  48. %attr(755,root,root) %{_sbindir}/*
  49. %{_datadir}/ipmitool/*
  50. %{_mandir}/man*/*
  51. %doc %{_datadir}/doc/ipmitool
  52. %changelog
  53. * Wed Feb 25 2009 <pere@hungry.com> 1.8.11-1
  54. - Fix new GCC compilation issues in regards to Packing
  55. - Fix Tracker bug #1642710 - ipmi_kcs_drv being loaded/unloaded
  56. for 2.4 kernel instead of ipmi_si_drv driver module
  57. - New -y option added to allow specification of kg keys with
  58. non-printable characters
  59. - New -K option added to allow kgkey settings via environmental
  60. variable IPMI_KGKEY
  61. - Generic device support added for EEPROM with SDR Type 10h (gendev)
  62. - Fix to lan-bridging for a double-bridging crash and to fix
  63. an issue with bridging multiple concurrent requests and
  64. erroneous handling of raw Send Message
  65. - Lanplus fix for commands like 'sensor list' without the -t option
  66. causing wrong double bridged requests of a sensor is located
  67. on another satellite controller
  68. - Fix lan and lanplus request list entry removal bugs
  69. - Fix non-working issue when trying to send a bridge message with
  70. Cipher 3
  71. - Change bridge message handling to reuse command ipmi_lan_poll_recv
  72. - Added PICMG 2.0 and 2.3 support
  73. - Fix PICMG (ATCA) extension verification and reversal of BCD encoded
  74. values for "major" and "minor" fields
  75. - Add IANA support for Pigeon Point
  76. - Add OEM SW/FW Record identification
  77. - Fix to include I2C and LUN addresses so sensors are correctly managed
  78. - Patch ID 1990560 to get readings from non-linear analog sensors
  79. - Add support for SOL payload status command
  80. - SOL set parameter range checking added
  81. - Fixed SOL activate options usage
  82. - Fixed crashes when parsing 'sol payload' and 'tsol' cmds (#216967)
  83. - Added retries to SOL keepalive
  84. - Fixed wrong mask values for Front Panel disable/enable status
  85. - Add support to access fru internal use area
  86. - Add support for new PICMG 3.0 R3.0 (March 24, 2008) to allow
  87. blocks of data within the FRU storage area to be write protected.
  88. - Fix node reporting in GUID; Tracker bug #2339675
  89. - Fix watchdog use/action print strings
  90. - Fix endian bug in SDR add from file; Tracker bug #2075258
  91. - Fix crash when dumping SDRs in a file and there's an error
  92. getting an SDR; improve algorithm for optimal packet size
  93. - Fix occasional SDR dump segfault; #1793076
  94. - Allow ipmitool sel delete to accept hex list entry numbers
  95. - Fix SEL total space reporting.
  96. - Fix for garbage sensor threshold values reported when none
  97. returned. Tracker Bug #863748
  98. - ipmievd change to Monitor %used in SEL buffer and log warnings when
  99. the buffer is 80% and 100% full
  100. * Fri Aug 08 2008 <pere@hungry.com> 1.8.10-1
  101. - Added support for BULL IANA number.
  102. - Fixed contrib build so the oem_ibm_sel_map file gets included in rpm
  103. builds again.
  104. - Added support for Debian packages to be built from CVS
  105. - Fix for sdr and sel timestamp reporting issues
  106. - Fix for discrete sensor state print routines to address state bits 8-14
  107. - Change ipmi_chassis_status() to non-static so it can be used externally
  108. - Added retries to SOL keepalive
  109. - Fix to stop sensor list command from reporting a failure due to missing
  110. sensor
  111. - Fix bug in sdr free space reporting
  112. - Add support for IANA number to vendor name conversion for many vendors
  113. - Fix segfault bug in lan set command
  114. - Fix bug in population of raw i2c wdata buffer
  115. - Fix bug in ipmb sensor reading
  116. - Fix misspellings, typos, incorrect strncmp lengths, white space
  117. - Update/fix printed help and usages for many commands
  118. - Add and update support for all commands in ipmitool man page
  119. - Fix for lanplus session re-open when the target becomes unavailable following
  120. a fw upgrade activation
  121. - Add support for watchdog timer shutoff, reset, and get info
  122. - Add support for more ibm systems in oem_ibm_sel_map
  123. - Add more JEDEC support info for DIMMs; decrease request size for DIMM FRU
  124. info to 16 bytes at a time to allow more DIMM FRUs to respond.
  125. - Fix to change hpmfwupg to version 1.02; fix to reduce hpmfwupg buffer
  126. length more aggressively when no response from iol
  127. - Fix HPM firmware activation via IOL; fake a timeout after IOL session
  128. re-open to force get upgrade status retry; Added retries on 0xD3
  129. completion code
  130. - Add support for freeipmi 0.6.0; adjust autoconf for changes
  131. - Fix for oemval2str size
  132. - Add support for product name resolution in mc info
  133. - Fix FRU display format
  134. - Added PICMG ekeying analyzer module support (ekanalyzer); display point
  135. to point physical connectivity and power supply information between
  136. carriers and AMC modules; display matched results of ekeying match
  137. between an on-carrier device and AMC module or between 2 AMC modules
  138. - Fix AMC GUID display support
  139. - Improved amcportstate operations
  140. - Added resolution for new sensor types
  141. - Fix segfault in SOL
  142. - Fix bug that caused infinite loop on BMCs with empty SDRs
  143. - Fix to move out Kontron OEM sensor resolution for other OEMs which could
  144. lead to bad event descriptions
  145. - Add new FRU edit mode thereby allowing serial numbers, etc. to be changed;
  146. improvements to OEM edit mode
  147. - Added SPD support for parms: channel number, max read size
  148. - Add SDR support for adding SDR records from a dumped file, clearing SDR,
  149. adding partial SDR records
  150. - Add updates and fixes to hpmfwupg: upload block size to 32 bytes for KCS,
  151. handle long response option, implement rollback override, garbage output fix
  152. - Add double bridge lan support , fix bridging issue
  153. - Add HPM support to pre-check which components need to be skipped
  154. - Fix autodetection of maximum packet size when using IPMB
  155. - Add new Kontron OEM command to set the BIOS boot option sequence
  156. - Add support for dual-bridge/ dual send message
  157. - Add auto-detect for local IPMB address using PICMG 2.X extension
  158. - Add support for HPM.1 1.0 specification compliance
  159. - Fix for improper lan/lanplus addressing
  160. - Added transit_channel and transit_addr to ipmi_intf struct
  161. - Fix bad password assertion bug due to rakp2 HMAC not being checked properly
  162. - Added ability to interpret PPS shelf manager clia sel dump
  163. - Corrected PICMG M7 state event definition macros
  164. - Added FRU parsing enhancements
  165. - Added "isol info", "isol set" and "isol activate" commands to support
  166. Intel IPMI v1.5 SOL functionality. Removed "isol setup" command.
  167. - Fix bug in ipmi_lan_recv_packet() in lan and lanplus interfaces.
  168. - Fix bug in "chassis poh" command.
  169. - Fix HPM.1 upgrade to apply to only given component when instructed to do so
  170. - Added configure auto-detection if dual bridge extension is supported
  171. by OpenIPMI
  172. * Tue Mar 6 2007 <pere@hungry.com> 1.8.9-1
  173. - Added initial AMC ekey query operation support
  174. - Improvements to ekeying support (PICMG 3.x only)
  175. - Added initial interactive edition support for multirec; added IANA
  176. verification before interpreting PICMG records.
  177. - Added edit support for AMC activation "Maximum Internal Current"
  178. - Fix bug generating garbage on the screen when handling GetDeviceId
  179. and sol traffic occurs
  180. - Added ability to map OEM sensor types to OEM description string using
  181. IANA number; moved IANA number table
  182. - Fix lan set access command to use value already saved within parameters
  183. for PEF and authentication
  184. - Fix bug in cmd ipmitool lan stats get 1
  185. - Add support to allow ipmitool/ipmievd to target specific device nodes
  186. on multi-BMC systems
  187. - Add support for name+privilege lookup for lanplus sessions
  188. - Fix time_t conversion bug for 64-bit OS
  189. - Added prefix of hostname on sel ipmievd sessions
  190. - Fixed FWUM Get Info
  191. - Fix ipmievd fd closing bug
  192. - Add set-in-progress flag support to chassis bootdev
  193. - Added new chassis bootdev options
  194. - Add sol payload enable/disable comman
  195. - Fix SOL set errors when commit-write not supported
  196. - Fix reset of session timeout for lanplus interface
  197. - Fixed lan interface accessibility timeout handling
  198. - Fix bug with Function Get Channel Cipher Suites command when more
  199. than 1 page used.
  200. - Fix missing firmware firewall top-level command
  201. - Fix bug in SOL keepalive functionality
  202. - Fix SOLv2 NACK and retry handling for Intel ESB2 BMC
  203. - Added ipmi_sel_get_oem_sensor* APIs
  204. - Added HPM.1 support
  205. - Fix segfault when incorrect oem option supplied
  206. - Fix bus problem with spd command
  207. - Fix segfault in SOL when remote BMC does not return packet
  208. - Adjust packet length for AMC.0 retricting IPMB packets to 32 bytes
  209. - Added lan packet size reduction mechanism
  210. - Fix bug with sendMessage of bad length with different target
  211. - Fix for big endian (PPC) architecture
  212. - NetBSD fixes
  213. - Fix segfault and channel problem with user priv command
  214. - Add support for bus/chan on i2c raw command
  215. - Add freeipmi interface support
  216. - Add remote spd printing
  217. - Add better detection of linux/compiler.h to config
  218. - Makefile changes to fix makedistcheck, etc.
  219. * Tue May 02 2006 <duncan@iceblink.org> 1.8.8-1
  220. - Fix segfaults in sensor data repository list
  221. - Fix ipmievd to open interface before daemonizing
  222. - Fix IPMIv1.5 authtype NONE to ignore supplied password
  223. - Fix cipher suite display bug in lan print
  224. - Fix typo in IPMIv2 SOL output when sending break
  225. - Fix improper LUN handling with Tyan SOL
  226. - Add LUN support to OpenIPMI interface
  227. - Add support for Kontron OEM commands
  228. - Update to Kontron Firmware Update command
  229. * Sun Mar 19 2006 <duncan@iceblink.org> 1.8.7-1
  230. - Add Sun OEM command for blades
  231. - Increase argument size for raw commands in shell/exec
  232. - Fix handling of LUNs for LAN interfaces
  233. - Add IPMIv2 SOL loopback test
  234. - Add support for IBM OEM SEL messages
  235. - Disable file paranoia checks on read files by default
  236. - Support IPMIv2 SOL on older Intel boxes
  237. - Display message and exit if keepalive fails during SOL
  238. - Add support for setting VLAN id and priority
  239. - Add support for FreeBSD OpenIPMI-compatible driver
  240. - Add support for IPMIv2 Firmware Firewall
  241. - Fix gcc4 compile warnings
  242. - Make ipmievd generate pidfile
  243. - Add initscripts for ipmievd
  244. * Mon Jan 17 2006 <duncan@iceblink.org> 1.8.6-1
  245. - Fix memory corruption when sending encrypted SOL traffic
  246. - Add keepalive timer to IPMIv2 SOL sessions
  247. * Sat Jan 14 2006 <duncan@iceblink.org> 1.8.5-1
  248. - Raise privilege level after creating IPMIv2 session
  249. - Add support for settable SOL escape character with -e option
  250. - Add support for Kg BMC key for IPMIv2 authentication with -k option
  251. - Add support for Tyan IPMIv1.5 SOL with tsol command
  252. - Add support for PICMG devices
  253. - Add support for OEM SEL event parsing
  254. - Add support for command bridging over lan and lanplus interfaces
  255. - New 'chassis selftest' command
  256. - Many bufxies and patches from contributors
  257. * Wed May 18 2005 <duncan@iceblink.org> 1.8.2-1
  258. - Fix FRU reading for large (>255 bytes) areas.
  259. - Overhaul to ipmievd to support SEL polling in addition to OpenIPMI.
  260. - Fix LAN parameter segfault when no Ciphers supported by BMC.
  261. - Fix IPMIv2 support on Intel v2 BMCs (use -o intelplus).
  262. - Separate option parsing code from main ipmitool source file.
  263. - Add raw I2C support with IPMI Master Read-Write command.
  264. - Add support for new 'sdr elist' extended output format.
  265. - Add support for listing sensors by type with 'sdr type' command.
  266. - Add support for new 'sel elist' extended output format that
  267. cross-references events with sensors.
  268. - Add support for sending dynamically generated platform events
  269. based on existing sensor information.
  270. - New '-S' argument to read local SDR cache created with 'sdr dump'.
  271. - Updated manpage for ipmitool and ipmievd.
  272. * Wed Apr 06 2005 <duncan@iceblink.org> 1.8.1-1
  273. - Install ipmievd into /usr/sbin
  274. * Wed Mar 16 2005 <duncan@iceblink.org> 1.8.0-1
  275. - Fix IPMIv2.0 issues
  276. - Fix chassis boot parameter support
  277. - Add support for linear sensors
  278. - Update bmc plugin to work with new Solaris bmc driver (new ioctl
  279. for interface detection and new STREAMS message-based interface)
  280. * Tue Jan 18 2005 <duncan@iceblink.org> 1.7.0-1
  281. - Propogate errors correctly so exit status will be useful
  282. - More consistent display of errors including completion code text
  283. - Errors and debug is send to stderr now
  284. - New "sel get" command that will print details about SEL entry
  285. and corresponding SDR records as well as FRUs via entity association
  286. - Improved event generator, now supports reading events from text file
  287. - New "-o oemtype" option for specifying OEM boards
  288. exsting types are "supermicro" and "intelwv2"
  289. - New PEF subsystem from Tim Murphy at Dell
  290. - New "bmc" plugin for Solaris 10 x86
  291. - Many bugfixes and contributed patches
  292. - Support for Supermicro BMC OEM authentication method
  293. - Fix minor problem with LAN parameter setting
  294. * Wed Aug 18 2004 <duncan@iceblink.org> 1.6.0-1
  295. - Add a README
  296. - Add support for IPMIv2 and Serial-over-LAN from Newisys
  297. - Add Solaris x86 lipmi interface
  298. - Add support for building Solaris packages
  299. - Add support for building RPMs as non-root user
  300. - Fix segfault when doing "sel list" (from Matthew Braithwaite)
  301. - Fix "chassis identify" on some BMCs (from ebrower@sourceforge)
  302. - Add "bmc info" and related output (from ebrower@sourceforge)
  303. - new "shell" and "exec" commands
  304. - lots of other contributed patches
  305. * Sat May 27 2004 <duncan@iceblink.org> 1.5.9-1
  306. - Add ability to get a particular sensor by name
  307. - Add ability to set a particular sensor threshold
  308. - Add support for displaying V2 channel authentication levels
  309. - Add README for rrdtool scripts in contrib directory
  310. - Improve lan interface retry handling
  311. - Support prompting for password or reading from environment
  312. - Move chaninfo command into channel subcommand
  313. - Fix reservation ID handling when two sessions open to BMC
  314. - Fix reading of large FRU data
  315. - Add configure option for changing binary to ipmiadm for Solaris
  316. - Fix compile problem on Solaris 8
  317. * Tue Jan 27 2004 <duncan@iceblink.org> 1.5.8-1
  318. - Enable static compilation of interfaces
  319. - Fix types to be 64-bit safe
  320. - Fix compilation problems on Solaris
  321. - Fix multiple big-endian problems for Solaris/SPARC
  322. - Fix channel access to save settings to NVRAM
  323. - Set channel privilege limit to ADMIN during "access on"
  324. - Enable gratuitous ARP in bmcautoconf.sh
  325. - Add support for Linux kernel panic messages in SEL output
  326. - Add support for type 3 SDR records
  327. * Mon Jan 5 2004 <duncan@iceblink.org> 1.5.7-1
  328. - add IPMIv1.5 eratta fixes
  329. - additions to FRU printing and FRU multirecords
  330. - better handling of SDR printing
  331. - contrib scripts for creating rrdtool graphs
  332. * Thu Dec 4 2003 <duncan@iceblink.org> 1.5.6-1
  333. - Fix SEL event decoding for generic events
  334. - Handle empty SEL gracefully when doing "sel list"
  335. - Fix sdr handling of sensors that do not return a reading
  336. - Fix for CSV display of sensor readings/units from Fredrik Öhrn
  337. * Tue Nov 25 2003 <duncan@iceblink.org> 1.5.5-1
  338. - Add -U option for setting LAN username
  339. - Fix -v usage for plugin interfaces
  340. * Fri Nov 14 2003 <duncan@iceblink.org> 1.5.4-1
  341. - pull interface plugin api into library
  342. - fix ipmievd
  343. * Fri Oct 31 2003 <duncan@iceblink.org> 1.5.3-1
  344. - add -g optin for pedantic ipmi-over-lan communication
  345. * Fri Oct 24 2003 <duncan@iceblink.org> 1.5.2-1
  346. - add gratuitous arp interval setting
  347. * Wed Oct 8 2003 <duncan@iceblink.org> 1.5.1-1
  348. - better SEL support
  349. - fix display bug in SDR list
  350. * Fri Sep 5 2003 <duncan@iceblink.org> 1.5.0-1
  351. - use automake/autoconf/libtool
  352. - dynamic loading interface plugins
  353. * Wed May 28 2003 <duncan@iceblink.org> 1.4.0-1
  354. - make UDP packet handling more robust
  355. - fix imb driver support
  356. * Thu May 22 2003 <duncan@iceblink.org> 1.3-1
  357. - update manpage
  358. - rework of low-level network handling
  359. - add basic imb driver support
  360. * Wed Apr 2 2003 <duncan@iceblink.org> 1.2-1
  361. - change command line option parsing
  362. - support for more chassis commands
  363. * Tue Apr 1 2003 <duncan@iceblink.org> 1.1-1
  364. - minor fixes.
  365. * Sun Mar 30 2003 <duncan@iceblink.org> 1.0-1
  366. - Initial release.